Back to overview
Resolved
AllCareers is down
Jul 8, 2026 at 1:57pm UTC
Affected services
AllCareers Website
Resolved
Jul 9, 2026 at 1:40pm UTC
We have fully identified and fixed the issue with AllCareers. We apologise for the inconvenience this has caused. In the rare event of data loss, you can request a retrieval by emailing info@cirkledevelopment.co.uk. Thank you for your cooperation.
Affected services
Created
Jul 8, 2026 at 1:57pm UTC
A published update has caused the entire website to crash and break. Therefore, the website is inaccessible until further notice. Careers enquiries can be sent to careers@cirkledevelopment.co.uk in the mean time. We apologise for the inconvenience this may cause.
Affected services