Back to overview
Resolved

Online Account Retrieval

Jul 17, 2026 at 6:03pm UTC
Affected services
Cirkle Development Shop

Resolved
Jul 17, 2026 at 10:18pm UTC

This has been resolved. Be also be aware that you may only have a registered account after buying a product/service from our website. If you use a different email to the one you used to purchase, you won't be able to log in as it in unregistered. Data retrieval during this time period can be requested at mydata@cirkledevelopment.co.uk

Created
Jul 17, 2026 at 6:03pm UTC

An issue has been identified whereas security codes are failing to be sent to your email and therefore, you cannot access your shop.cirkledevelopment.co.uk account. We will try to get this resolved as soon as possible. No data has been lost. For data requests, please email mydata@cirkledevelopment.co.uk. If you wish to get ahold of your products, please do so by email. Otherwise, we'd be happy to assist in a ticket. We apologise for the inconvenience this has/may cause(d).